Follow americannetworkinstitute.ml

ads
test

CCNA LAB, Static Routing, Step by Step



In this lab we will simulate 4 routers: 1 Corporate office and the other branch in NY, Miami and Fort Lauderdale  (where I live)  . We will configure static routing..




First of all , please pay attention to details , network and interfaces on the diagram.
We made it on packet tracer but you can do it in other real life or GNS3 simulator



Router>
Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Changing router name
Router(config)#hostname CORP
CORP(config)#enable secret  labclass
Creating an Username and password   to be using while telneting into the router
CORP(config)#username victor password cisco
CORP(config)#service password-encryption
Configuring the line VTY
CORP(config)#line vty 0 15
CORP(config-line)#login local
CORP(config-line)#line cons 0

               
CORP(config-line)#login
% Login disabled on line 0, until 'password' is set
CORP(config-line)#password cisco1
CORP(config-line)#
Now pay close attention to each interface on your diagram

Configuring the interface to Access point, this case Fastethernet0/0
CORP(config-line)#int fa0/0
CORP(config-if)#ip address 10.1.1.1 255.255.255.0
CORP(config-if)#no shut

CORP(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Configuring the interface Serial 0/0/0
CORP(config-if)#int s0/0/0
CORP(config-if)#ip address 10.1.3.1 255.255.255.0
CORP(config-if)#description FIRST LINK TO NY ROUTER
               
CORP(config-if)#clock rate 148000
This command applies only to DCE interfaces
               
CORP(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Configuring the int serial 0/1/0
CORP(config-if)#int s0/1/0
CORP(config-if)#ip address 10.1.2.1 255.255.255.0
CORP(config-if)#description SECOND LINK TO NY ROUTER
CORP(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
CORP(config-if)#

Configuring  the interface 0/2/0
CORP(config)#int s0/2/0
CORP(config-if)#ip address 10.1.4.1 255.255.255.0
CORP(config-if)#description LINK TO MIAMI ROUTER
CORP(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/2/0, changed state to down
Configuring  the interface serial 0/3/0
CORP(config-if)#int s0/3/0
   
CORP(config-if)#ip address 10.1.5.1 255.255.255.0
CORP(config-if)#description LINK TO FORT LAUDERDALE ROUTER
CORP(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/3/0, changed state to down
CORP(config-if)#
Configuring static route

CORP(config)#ip route 10.1.6.0 255.255.255.0 10.1.2.2
CORP(config)#ip route 10.1.7.0 255.255.255.0 10.1.3.2






Because between Corp router and NY Router we have a redundant link, we can one link  most prefered than another one , assuming it's the faster link.
We can accomplish this using the metric parameter when configuring the static router as follow:

CORP(config)#ip route 10.1.6.0 255.255.255.0 10.1.3.2 150
CORP(config)#ip route 10.1.7.0 255.255.255.0 10.1.2.2 151


CORP(config)#ip route 10.1.8.0 255.255.255.0 10.1.4.2
CORP(config)#ip route 10.1.9.0 255.255.255.0 10.1.4.2
CORP(config)#ip route 10.1.10.0 255.255.255.0 10.1.5.2
CORP(config)#ip route 10.1.11.0 255.255.255.0 10.1.5.2

We will save this configuration
CORP(config)#do copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
CORP(config)#

Now let's start  to Configure NY Router
        --- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]:
% Please answer 'yes' or 'no'.
Continue with configuration dialog? [yes/no]: n


Press RETURN to get started!



Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname NY
NY(config)#line vty 0 15
NY(config-line)#login local
NY(config-line)#password cisco
NY(config-line)#line cons 0
NY(config-line)#login
% Login disabled on line 0, until 'password' is set
NY(config-line)#password cisco1
Configuration on FastEthernet 0/0
NY(config-line)#int f0/0
NY(config-if)#ip address 10.1.6.1 255.255.255.0
NY(config-if)#no shut

NY(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Configuration on FastEthernet 0/1
NY(config-if)#int f0/1
NY(config-if)#ip address 10.1.7.1 255.255.255.0
NY(config-if)#no shut

NY(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Configuration of serial0/0/0
NY(config-if)#int s0/0/0
NY(config-if)#ip address 10.1.2.2 255.255.255.0
NY(config-if)#clock rate 148000
NY(config-if)#no shut

NY(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Now look how the interface  this turn up with green colors and the interface show up it's up

Configure interface serial 0/1/0
NY(config-if)#int s0/1/0
NY(config-if)#ip address 10.1.3.2 255.255.255.0 
NY(config-if)#description SECOND LINK TO CORP ROUTER
NY(config-if)#no shut

NY(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
Configuring Static routes

NY(config-if)#ip route 10.1.1.0 255.255.255.0 10.1.2.1
NY(config)#ip route 10.1.8.0 255.255.255.0 10.1.2.1
NY(config)#ip route 10.1.9.0 255.255.255.0 10.1.2.1
NY(config)#ip route 10.1.10.0 255.255.255.0 10.1.2.1


Because we have a redundant link between NY and Corp routers , we can make one preferred than the other .We can accomplish this using metric parameter when configuring an static routes:

NY(config)#ip route 10.1.1.0 255.255.255.0 10.1.2.1 150
NY(config)#ip route 10.1.8.0 255.255.255.0 10.1.2.1 150
NY(config)#ip route 10.1.9.0 255.255.255.0 10.1.2.1 150
NY(config)#ip route 10.1.10.0 255.255.255.0 10.1.2.1 150
NY(config)#ip route 10.1.11.0 255.255.255.0 10.1.2.1 150


Let's Configure Miami Router


We are not going to describe some similar steps that we use before
Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#line vty 0 15
Router(config-line)#login local
Router(config-line)#password cisco
Router(config-line)#line cons 0

Router(config-line)#password cisco1
Router(config-line)#
Router(config-line)#int fa0/0
Router(config-if)#ip address 10.1.8.1 255.255.255.0

   
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#int f0/1
Router(config-if)#ip address 10.1.9.1 255.255.255.0
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Configuring serial 0/0/0
Router(config-if)#int serial 0/0/0
Router(config-if)#ip address 10.1.4.2 255.255.255.0
Router(config-if)#description LINK TO CORP Router
Router(config-if)#clock rate 148000
Router(config-if)#no shut

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Now they are up, we will configure the static Routes

Router(config)#ip route 10.1.1.0 255.255.255.0 10.1.4.1
Router(config)#ip route 10.1.6.0 255.255.255.0 10.1.4.1
Router(config)#ip route 10.1.7.0 255.255.255.0 10.1.4.1
Router(config)#ip route 10.1.10.0 255.255.255.0 10.1.4.1
Router(config)#ip route 10.1.11.0 255.255.255.0 10.1.4.1








Because Miami Router is consider a spoke router or a stub network  with only one way to get out we can replace the five individuals static routes  by one default route, to accomplish the same goal as follow


Option 1
NY(config)#ip route 0.0.0.0 0.0.0.0 10.1.4.1
Option 2
NY(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0

Option 3
NY(config)#ip default-network 10.1.4.0

Now we can see the difference in the graphic



Now let's do our final Router Fort Lauderdale ( My town)
Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname FortLauderdale

 -----------------------------------
 fortlauderdale(config)#line vty 0 15
fortlauderdale(config-line)#login local
fortlauderdale(config-line)#password cisco
fortlauderdale(config-line)#line cons 0
fortlauderdale(config-line)#password cisco1
fortlauderdale(config-line)#int fa0/0
fortlauderdale(config-if)#ip address 10.1.8.1 255.255.255.0
fortlauderdale(config-if)#no shut

fortlauderdale(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Configuration of interface 0/1
fortlauderdale(config-if)#int f0/1
fortlauderdale(config-if)#ip address 10.1.9.1 255.255.255.0
fortlauderdale(config-if)#no shut

fortlauderdale(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

fortlauderdale(config-if)#int f0/0
fortlauderdale(config-if)#ip address 10.1.10.1 255.255.255.0
fortlauderdale(config-if)#no shut
fortlauderdale(config-if)#
fortlauderdale(config-if)#int f0/1
fortlauderdale(config-if)#ip address 10.1.11.1 255.255.255.0
fortlauderdale(config-if)#no shut
fortlauderdale(config-if)#int serial 0/0/0
fortlauderdale(config-if)#ip address 10.1.5.2 255.255.255.0
fortlauderdale(config-if)#description LINK TO CORP Router
fortlauderdale(config-if)#clock rate 148000
fortlauderdale(config-if)#no shut

Configuration of serial 0/3/0
fortlauderdale(config-if)#int serial 0/3/0
fortlauderdale(config-if)#ip address 10.1.5.2 255.255.255.0
fortlauderdale(config-if)#no shut

fortlauderdale(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/3/0, changed state to up


Configuration of static routes

ip route 10.1.1.0 255.255.255.0 10.1.5.1

fortlauderdale(config)#ip route 10.1.6.0 255.255.255.0 10.1.5.1
fortlauderdale(config)#ip route 10.1.7.0 255.255.255.0 10.1.5.1
fortlauderdale(config)#ip route 10.1.9.0 255.255.255.0 10.1.5.1
fortlauderdale(config)#ip route 10.1.8.0 255.255.255.0 10.1.5.1




Because Fort lauderdale  Router is consider a spoke router or a stub network  with only one way to get out we can replace the five individuals static routes  by one default route, to accomplish the same goal as follow
Option 1
FortLauderdale(config)#ip route 0.0.0.0 0.0.0.0 10.1.5.1
Option 2
FortLauderdale(config)#ip route 0.0.0.0 0.0.0.0 serial 0/3/0
Option 3
FortLauderdale(config)#ip default-network 10.1.5.0

Now we can see the difference in the graphic




fortlauderdale(config)#exit


 --------------------
CCNA LAB, Static Routing, Step by Step CCNA LAB, Static Routing, Step by Step Reviewed by ohhhvictor on 8:39 AM Rating: 5

No comments:

Powered by Blogger.